You Should Update LoTW tQSL Software

You should update LoTW tQSL software if you are using a version older than 2.0, that is.

You Should Update LoTW tQSL Software

ARRL’s Logbook of The World will no longer accept contacts signed with tQSL versions earlier than 2.0. This will apply starting January 16th 2017, 14:00 UTC. If you are using an earlier version than 2.0, ARRL encourages you to upgrade as soon as possible.

tQSL is the software offered free by ARRL, that allows amateur radio operators to upload their logs to Logbook of The World. It is available for Linux, macOS and Windows. The program can be downloaded here. The latest version, as of this post, is 2.3.

Source.

Don’t forget to checkout the (unofficial) mobile app for LoTW, available for Android and iOS, here.

Leave a Reply